EasyBeans
  1. EasyBeans
  2. EZB-227

Using Configuration Service when initializing EasyBeans-Osgi

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: EasyBeans 1.0 RC4
    • Component/s: OSGi
    • Labels:
      None
    • Environment:
      linux
    • Global Rank:
      2557

      Description

      I am facing an issue concerning the initialization of easybeans-osgi.
      That is:

      -We would like to deploy easybeans-osgi bundles onto our clustered application server.
      -There are many hosts, with many running osgi frameworks.
      -All bundle parameters are stored centrally in a database, and all bundles retrieve their configuration using the standard Osgi "Configuration Admin Service".

      -> The problem is: in my understanding (fixme ??) EasyBeans (agent) only loads parameters from a property file somewhere in the filesystem. But we don't/can't distribute the property file on all our hosts.

      it would be nice/great if easybeans-agent could load its initial configuration using a "ManagedService", in order to let the EZB agent loads its configuration from our "Configuration Admin" Service ..

        Activity

        Guillaume Sauthier
        added a comment -

        Now, we try to find a Configuration with the pid: "org.ow2.easybeans.configuration"
        and if we find one, try to read the "configuration.content" property value, and uses it in replacement of the easybeans.xml file

        Please close this issue if that solve the problem.
        Thanks

        Show
        Guillaume Sauthier
        added a comment - Now, we try to find a Configuration with the pid: "org.ow2.easybeans.configuration" and if we find one, try to read the "configuration.content" property value, and uses it in replacement of the easybeans.xml file Please close this issue if that solve the problem. Thanks
        Guillaume Sauthier
        added a comment -

        After resolve, close the issues

        Show
        Guillaume Sauthier
        added a comment - After resolve, close the issues

          People

          • Assignee:
            Guillaume Sauthier
            Reporter:
            de rop
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Issue deployment