JOnAS
  1. JOnAS
  2. JONAS-404

Jonas hibernate validation service is not present in the default repository. it needs an internet access to be downloaded.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: JOnAS 5.2.0
    • Fix Version/s: JOnAS 5.3.0 M2, JOnAS 5.2.1
    • Component/s: Persistence
    • Labels:
      None
    • Environment:
      Debian Squeeze

      Description

      Here is the stackTrace at Jonas's start :

      2011-04-12 14:57:31,896 : ServiceManagerImpl$1.run : Cannot start the 'validation' service
      org.ow2.util.ee.deploy.api.deployer.DeployerException: Cannot deploy the deployment plan for '/home/sbenoist/produits/jonas/repositories/url-internal/validation.xml'
      at org.ow2.jonas.services.bootstrap.JOnASDeploymentPlanDeployer.__deployDeploymentPlan(JOnASDeploymentPlanDeployer.java:127)
      at org.ow2.jonas.services.bootstrap.JOnASDeploymentPlanDeployer.deployDeploymentPlan(JOnASDeploymentPlanDeployer.java)
      at org.ow2.jonas.services.bootstrap.JOnASDeploymentPlanDeployer.__deploy(JOnASDeploymentPlanDeployer.java:83)
      at org.ow2.jonas.services.bootstrap.JOnASDeploymentPlanDeployer.deploy(JOnASDeploymentPlanDeployer.java)
      at org.ow2.jonas.lib.service.manager.ServiceManagerImpl.__startService(ServiceManagerImpl.java:403)
      at org.ow2.jonas.lib.service.manager.ServiceManagerImpl.startService(ServiceManagerImpl.java)
      at org.ow2.jonas.lib.service.manager.ServiceManagerImpl.__startService(ServiceManagerImpl.java:371)
      at org.ow2.jonas.lib.service.manager.ServiceManagerImpl.startService(ServiceManagerImpl.java)
      at org.ow2.jonas.lib.service.manager.ServiceManagerImpl$1.run(ServiceManagerImpl.java:499)
      Caused by: org.ow2.util.ee.deploy.api.deployer.DeployerException: Deployment plan deployment failed
      at org.ow2.util.plan.deployer.impl.DeploymentPlanDeployer.deploy(DeploymentPlanDeployer.java:154)
      at org.ow2.jonas.services.bootstrap.JOnASDeploymentPlanDeployer.__deployDeploymentPlan(JOnASDeploymentPlanDeployer.java:125)
      ... 8 more
      Caused by: org.ow2.util.plan.deployer.api.DeploymentPlanDeploymentException: Error while deploying part Maven2Deployment[org.ow2.jonas:jonas-validation-hibernate:jar:ipojo, reloadable=false, useRepository=<not set>] of deployment plan org.ow2.util.plan.bindings.deploymentplan.DeploymentPlan@41955c3
      at org.ow2.util.plan.deployer.impl.DeploymentPlanDeployer.deployDeploymentPlan(DeploymentPlanDeployer.java:278)
      at org.ow2.util.plan.deployer.impl.DeploymentPlanDeployer.deploy(DeploymentPlanDeployer.java:152)
      ... 9 more
      Caused by: org.ow2.util.plan.deployer.api.FragmentDeploymentException: org.ow2.util.plan.fetcher.api.exceptions.FetcherException: org.ow2.util.plan.fetcher.api.exceptions.ResourceNotFoundException: Maven2Deployment[org.ow2.jonas:jonas-validation-hibernate:jar:ipojo, reloadable=false, useRepository=<not set>]
      at org.ow2.util.plan.deployer.impl.DeploymentPlanDeployer.deployDeployment(DeploymentPlanDeployer.java:334)
      at org.ow2.util.plan.deployer.impl.DeploymentPlanDeployer.deployDeploymentPlan(DeploymentPlanDeployer.java:260)
      ... 10 more
      Caused by: org.ow2.util.plan.fetcher.api.exceptions.FetcherException: org.ow2.util.plan.fetcher.api.exceptions.ResourceNotFoundException: Maven2Deployment[org.ow2.jonas:jonas-validation-hibernate:jar:ipojo, reloadable=false, useRepository=<not set>]
      at org.ow2.util.plan.fetcher.impl.maven2.Maven2ResourceFetcher.resolve(Maven2ResourceFetcher.java:180)
      at org.ow2.util.plan.deployer.impl.DeploymentPlanDeployer.deployDeployment(DeploymentPlanDeployer.java:331)
      ... 11 more
      Caused by: org.ow2.util.plan.fetcher.api.exceptions.ResourceNotFoundException: Maven2Deployment[org.ow2.jonas:jonas-validation-hibernate:jar:ipojo, reloadable=false, useRepository=<not set>]
      ... 13 more

        Activity

        Florent Benoit added a comment -

        Fixed
        Your issue JONAS-404 looks like Error 404


          People

          • Assignee:
            Florent Benoit
            Reporter:
            Stéphane Benoist
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development